GitHub Advisoryadvisory · Go
GHSA-vfvf-6gx5-mqv6 Incorrect Authorization in ORY Oathkeeper
HIGH
Official page ↗
- Aliases
- CVE-2021-32701
- Ecosystem
- Go
- Packages
- github.com/ory/oathkeeper
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2021-06-23
Affected packages
• Go github.com/ory/oathkeeper: >= 0.38.0-beta.2, < 0.38.12-beta.1 → fixed in 0.38.12-beta.1
Description
ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access Rules. When you make a request to an endpoint that requires the scope `foo` using an access token granted with that `foo` scope, introspection will be valid and that token will be cached. The problem comes when a second requests to an endpoint that requires the scope `bar` is made before the cache has expired. Whether the token is granted or not to the `bar` scope, introspection will be valid. A patch will be released with `v0.38.12-beta.1`. Per default, caching is disabled for the `oauth2_introspection` authenticator. When caching is disabled, this vulnerability does not exist. The cache is checked in `func (a *AuthenticatorOAuth2Introspection) Authenticate(...)`. From `tokenFromCache()` it seems that it only validates the token expiration date, but ignores whether the token has or not the proper scopes. The vulnerability was introduced in PR #424. During review, we failed to require appropriate test coverage by the submitter which is the primary reason that the vulnerability passed the review process.
Related
Alias · CVE (1)
- CVE-2021-32701 ORY Oathkeeper is an Identity & Access Proxy (IAP) and Access Control Decision API that authorizes HTTP requests based on sets of Access… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness