GitHub Advisoryadvisory · Maven

GHSA-vfww-5hm6-hx2j Apache Tomcat Vulnerable to Improper Neutralization of Escape, Meta, or Control Sequences

LOW Published 2025-10-27 Modified 2026-05-13 Official page ↗
Aliases
CVE-2025-55754
Ecosystem
Maven
Packages
org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core, org.apache.tomcat:tomcat-catalina
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Weaknesses
CWE-150
Reviewed
2025-10-28

Affected packages

• Maven org.apache.tomcat:tomcat: >= 11.0.0-M1, < 11.0.11 → fixed in 11.0.11 • Maven org.apache.tomcat:tomcat: >= 10.1.0-M1, < 10.1.45 → fixed in 10.1.45 • Maven org.apache.tomcat:tomcat: >= 9.0.40, < 9.0.109 → fixed in 9.0.109 • Maven org.apache.tomcat:tomcat: >= 8.5.60, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 11.0.0-M1, < 11.0.11 → fixed in 11.0.11 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 10.1.0-M1, < 10.1.45 → fixed in 10.1.45 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 9.0.40, < 9.0.109 → fixed in 9.0.109 • Maven org.apache.tomcat.embed:tomcat-embed-core: >= 8.5.60, <= 8.5.100 (no fix yet) • Maven org.apache.tomcat:tomcat-catalina: >= 11.0.0-M1, < 11.0.11 → fixed in 11.0.11 • Maven org.apache.tomcat:tomcat-catalina: >= 10.1.0-M1, < 10.1.45 → fixed in 10.1.45 • Maven org.apache.tomcat:tomcat-catalina: >= 9.0.40, < 9.0.109 → fixed in 9.0.109 • Maven org.apache.tomcat:tomcat-catalina: >= 8.5.60, <= 8.5.100 (no fix yet)

Description

Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2025-55754 Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. vulnerability

Weakness · CWE (1)

  • CWE-150 Improper Neutralization of Escape, Meta, or Control Sequences weakness

References