GitHub Advisoryadvisory · npm, NuGet, Packagist

GHSA-vg35-5wq7-3x7w TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

HIGH Published 2026-06-05 Modified 2026-06-30 Official page ↗
Aliases
CVE-2026-47761
Ecosystem
npm, NuGet, Packagist
Packages
tinymce, TinyMCE, tinymce/tinymce
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
Weaknesses
CWE-79
Reviewed
2026-06-05

Affected packages

• npm tinymce: <= 5.10.9 (no fix yet) • npm tinymce: >= 6.0.0, < 7.9.3 → fixed in 7.9.3 • npm tinymce: >= 8.0.0, < 8.5.1 → fixed in 8.5.1 • NuGet TinyMCE: <= 5.10.9 (no fix yet) • NuGet TinyMCE: >= 6.0.0, < 7.9.3 → fixed in 7.9.3 • NuGet TinyMCE: >= 8.0.0, < 8.5.1 → fixed in 8.5.1 • Packagist tinymce/tinymce: <= 5.10.9 (no fix yet) • Packagist tinymce/tinymce: >= 6.0.0, < 7.9.3 → fixed in 7.9.3 • Packagist tinymce/tinymce: >= 8.0.0, < 8.5.1 → fixed in 8.5.1

Description

Impact Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted `data-mce-*` attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. Patches This vulnerability has been patched in TinyMCE 8.5.1, TinyMCE 7.9.3 and TinyMCE 5.11.1 LTS by ensuring that, when using the media plugin, any content with `data-mce-object` and `data-mce-p-*` attributes are properly sanitized. Workarounds No official workaround available. Fix To avoid this vulnerability: • Upgrade to TinyMCE 8.5.1 or higher. • Upgrade to TinyMCE 7.9.3 or higher. • Upgrade to TinyMCE 5.11.1 LTS or higher for TinyMCE 5.x (only available as part of commercial long-term support contract). Acknowledgements Tiny thanks Aymane MAZGUITI and Ange Primiterra for their help identifying this vulnerability.

Related

Alias · CVE (1)

  • CVE-2026-47761 TinyMCE is an open source rich text editor. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References