GitHub Advisoryadvisory · Go
GHSA-vg67-chm7-8m3j Mattermost allows remote actor to create/update/delete posts in arbitrary channels
HIGH
Official page ↗
- Aliases
- CVE-2024-41144
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:L
- Weaknesses
- CWE-284
- Reviewed
- 2024-08-02
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 9.5.0, < 9.5.7 → fixed in 9.5.7
• Go github.com/mattermost/mattermost/server/v8: >= 9.7.0, < 9.7.6 → fixed in 9.7.6
• Go github.com/mattermost/mattermost/server/v8: >= 9.8.0, < 9.8.2 → fixed in 9.8.2
• Go github.com/mattermost/mattermost/server/v8: >= 9.9.0, < 9.9.1 → fixed in 9.9.1
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20240619142046-8181a9ddffc0 → fixed in 8.0.0-20240619142046-8181a9ddffc0
• Go github.com/mattermost/mattermost: < 5.3.2-0.20240619142046-8181a9ddffc0 → fixed in 5.3.2-0.20240619142046-8181a9ddffc0
Description
Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly validate synced posts, when shared channels are enabled, which allows a malicious remote to create/update/delete arbitrary posts in arbitrary channels
Related
Alias · CVE (1)
- CVE-2024-41144 Mattermost versions 9.9.x <= 9.9.0, 9.5.x <= 9.5.6, 9.7.x <= 9.7.5, 9.8.x <= 9.8.1 fail to properly validate synced posts, when shared… vulnerability
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness