GitHub Advisoryadvisory · Maven
GHSA-vg6x-pchq-98mg OpenCMS Cross-Site Scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2024-5520
- Ecosystem
- Maven
- Packages
- org.opencms:opencms-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-30
Affected packages
• Maven org.opencms:opencms-core: >= 16.0, < 17.0 → fixed in 17.0
Description
Two Cross-Site Scripting vulnerabilities have been discovered in Alkacon's OpenCMS affecting version 16, which could allow a user:
with sufficient privileges to create and modify web pages through the admin panel, can execute malicious JavaScript code, after inserting code in the `title` field. Another could having the roles of gallery editor or VFS resource manager will have the permission to upload images in the .svg format containing JavaScript code. The code will be executed the moment another user accesses the image.
Related
Alias · CVE (1)
- CVE-2024-5520 Two Cross-Site Scripting vulnerabilities have been discovered in Alkacon's OpenCMS affecting version 16, which could allow a user with… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness