GitHub Advisoryadvisory · Maven

GHSA-vgg8-72f2-qm23 Critical severity vulnerability that affects org.eclipse.jetty:jetty-server

CRITICAL Published 2018-10-19 Modified 2021-06-10 Official page ↗
Aliases
CVE-2017-7657
Ecosystem
Maven
Packages
org.eclipse.jetty:jetty-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-190, CWE-444
Reviewed
2020-06-16

Affected packages

• Maven org.eclipse.jetty:jetty-server: < 9.2.25.v20180606 → fixed in 9.2.25.v20180606 • Maven org.eclipse.jetty:jetty-server: >= 9.3.0, < 9.3.24.v20180605 → fixed in 9.3.24.v20180605

Description

In Eclipse Jetty, versions 9.2.x and older, 9.3.x, transfer-encoding chunks are handled poorly. The chunk length parsing was vulnerable to an integer overflow. Thus a large chunk size could be interpreted as a smaller chunk size and content sent as chunk body could be interpreted as a pipelined request. If Jetty was deployed behind an intermediary that imposed some authorization and that intermediary allowed arbitrarily large chunks to be passed on unchanged, then this flaw could be used to bypass the authorization imposed by the intermediary as the fake pipelined request would not be interpreted by the intermediary as a request.

Related

Alias · CVE (1)

  • CVE-2017-7657 In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance… vulnerability

Weakness · CWE (2)

  • CWE-190 Integer Overflow or Wraparound weakness
  • CWE-444 Inconsistent Interpretation of HTTP Requests weakness

References