GitHub Advisoryadvisory · Maven
GHSA-vgvf-9jh3-fg75 Deserialization of Untrusted Data in swagger-codegen
HIGH
Official page ↗
- Aliases
- CVE-2017-1000207
- Ecosystem
- Maven
- Packages
- io.swagger:swagger-parser, io.swagger:swagger-codegen
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
- Reviewed
- 2020-06-16
Affected packages
• Maven io.swagger:swagger-parser: < 1.0.31 → fixed in 1.0.31
• Maven io.swagger:swagger-codegen: < 2.2.2 → fixed in 2.2.2
Description
A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.
Related
Alias · CVE (1)
- CVE-2017-1000207 A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary… vulnerability
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2017-1000207 advisory
- https://github.com/swagger-api/swagger-parser/pull/481 web
- https://github.com/advisories/GHSA-vgvf-9jh3-fg75 advisory
- https://github.com/swagger-api/swagger-parser package
- https://lgtm.com/blog/swagger_snakeyaml_CVE-2017-1000207_CVE-2017-1000208 web