GitHub Advisoryadvisory · Packagist
GHSA-vgxh-x8jv-hmff silverstripe/framework code execution vulnerability
HIGH
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/framework
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-74
- Reviewed
- 2024-05-27
Affected packages
• Packagist silverstripe/framework: >= 4.0.3-rc1, < 4.0.4 → fixed in 4.0.4
• Packagist silverstripe/framework: >= 4.1.0-rc1, < 4.1.1 → fixed in 4.1.1
Description
There is a vulnerability whereby arbitrary global functions may be executed if malicious user input is passed through to in the second argument of `ViewableData::renderWith`. This argument resolves associative arrays as template placeholders. This exploit requires that user code has been written which makes use of the second argument in `renderWith` and where user input is passed directly as a value in an associative array without sanitisation such as `Convert::raw2xml()`.
`ViewableData::customise` is not vulnerable.
Related
Weakness · CWE (1)
- CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
References
- https://github.com/silverstripe/silverstripe-framework/commit/6f50728b185e62c0087a58b295a015cb13276911 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2018-006-1.yaml web
- https://github.com/silverstripe/silverstripe-framework package
- https://www.silverstripe.org/download/security-releases/ss-2018-006 web