GitHub Advisoryadvisory · Maven

GHSA-vh98-fqfc-4hj3 Apache Geode vulnerable to Exposure of Sensitive Information

MEDIUM Published 2022-05-13 Modified 2022-11-08 Official page ↗
Aliases
CVE-2017-9797
Ecosystem
Maven
Packages
org.apache.geode:geode-core
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
Weaknesses
CWE-200
Reviewed
2022-11-08

Affected packages

• Maven org.apache.geode:geode-core: >= 1.0.0, < 1.2.1 → fixed in 1.2.1

Description

When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode and send metadata messages. These metadata operations could leak information about application data types. In addition, an attacker could perform a denial of service attack on the cluster.

Related

Alias · CVE (1)

  • CVE-2017-9797 When an Apache Geode cluster before v1.2.1 is operating in secure mode, an unauthenticated client can enter multi-user authentication mode… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References