GitHub Advisoryadvisory · Packagist
GHSA-vhg8-x858-7wq6 Drupal Cross-site scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2016-7571
- Ecosystem
- Packagist
- Packages
- drupal/core, drupal/drupal
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-23
Affected packages
• Packagist drupal/core: >= 8.0, < 8.1.10 → fixed in 8.1.10
• Packagist drupal/drupal: >= 8.0, < 8.1.10 → fixed in 8.1.10
Description
Cross-site scripting (XSS) vulnerability in Drupal 8.x before 8.1.10 allows remote attackers to inject arbitrary web script or HTML via vectors involving an HTTP exception.
Related
Alias · CVE (1)
- CVE-2016-7571 Cross-site scripting (XSS) vulnerability in Drupal 8.x before 8.1.10 allows remote attackers to inject arbitrary web script or HTML via… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2016-7571 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2016-7571.yaml web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2016-7571.yaml web
- https://github.com/drupal/core package
- https://www.drupal.org/SA-CORE-2016-004 web
- http://www.securityfocus.com/bid/93101 web
- http://www.securitytracker.com/id/1036886 web