GitHub Advisoryadvisory · Go

GHSA-vhgh-g7x8-4rx8 Mattermost doesn't validate decompressed archive entry sizes during file extraction

MEDIUM Published 2026-03-26 Modified 2026-03-31 Official page ↗
Aliases
CVE-2026-3114
Ecosystem
Go
Packages
github.com/mattermost/mattermost/server/v8
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-409
Reviewed
2026-03-31

Affected packages

• Go github.com/mattermost/mattermost/server/v8: >= 11.4.0, < 11.4.1 → fixed in 11.4.1 • Go github.com/mattermost/mattermost/server/v8: >= 11.3.0, < 11.3.2 → fixed in 11.3.2 • Go github.com/mattermost/mattermost/server/v8: >= 11.2.0, < 11.2.4 → fixed in 11.2.4 • Go github.com/mattermost/mattermost/server/v8: >= 10.11.0, < 10.11.12 → fixed in 10.11.12 • Go github.com/mattermost/mattermost/server/v8: >= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b → fixed in 8.0.0-20260217110922-b7d4a1f1f59b

Description

Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate decompressed archive entry sizes during file extraction which allows authenticated users with file upload permissions to cause a denial of service via crafted zip archives containing highly compressed entries (zip bombs) that exhaust server memory. Mattermost Advisory ID: MMSA-2026-00598.

Related

Alias · CVE (1)

  • CVE-2026-3114 Mattermost versions 11.4.x <= 11.4.0, 11.3.x <= 11.3.1, 11.2.x <= 11.2.3, 10.11.x <= 10.11.11 fail to validate decompressed archive entry… vulnerability

Weakness · CWE (1)

  • CWE-409 Improper Handling of Highly Compressed Data (Data Amplification) weakness

References