GitHub Advisoryadvisory · Packagist

GHSA-vhm8-wwrf-3gcw Path Traversal Vulnerability in `LESS` Parser allows reading of sensitive server files

MEDIUM Published 2023-03-13 Modified 2023-03-13 Official page ↗
Aliases
CVE-2023-27577
Ecosystem
Packagist
Packages
flarum/core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-22
Reviewed
2023-03-13

Affected packages

• Packagist flarum/core: < 1.7.0 → fixed in 1.7.0

Description

Impact If an admin account has already been compromised by an attacker, the `LESS` parser can be exploited to read sensitive files on the server through the use of path traversal techniques. An attacker can achieve this by providing an absolute path to a sensitive file in the custom `LESS` setting, which the `LESS` parser will then read. For example, an attacker could use the following code to read the contents of the `/etc/passwd` file: ```less @import (inline) '/etc/passwd'; .test { content: data-uri('/etc/passwd'); } ``` Patches The vulnerability has been addressed in version `1.7`. Users should upgrade to this version to mitigate the vulnerability. Workarounds Users can mitigate the vulnerability by ensuring that their admin accounts are secured with strong passwords and other best practices for account security. Additionally, users can limit the exposure of sensitive files on the server by implementing appropriate file permissions and access controls.

Related

Alias · CVE (1)

  • CVE-2023-27577 flarum is a forum software package for building communities. vulnerability

Weakness · CWE (1)

  • CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness

References