GitHub Advisoryadvisory · Go
GHSA-vj4m-83m8-xpw5 OpenFGA Authorization Bypass via tupleset wildcard
MEDIUM
Official page ↗
- Aliases
- CVE-2022-39341
- Ecosystem
- Go
- Packages
- github.com/openfga/openfga
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-285, CWE-863
- Reviewed
- 2022-10-25
Affected packages
• Go github.com/openfga/openfga: < 0.2.4 → fixed in 0.2.4
Description
Overview
During our internal security assessment, it was discovered that OpenFGA versions `v0.2.3` and prior are vulnerable to authorization bypass under certain conditions.
Am I affected?
You are affected by this vulnerability if you are using `openfga/openfga` version `v0.2.3` and you added a tuple with a wildcard (*) assigned to a tupleset relation (the right hand side of a ‘from’ statement).
How to fix that?
Upgrade to version `v0.2.4`.
Backward Compatibility
This update is not backward compatible with any authorization model that uses wildcard on a tupleset relation.
Related
Alias · CVE (1)
- CVE-2022-39341 OpenFGA is an authorization/permission engine. vulnerability
References
- https://github.com/openfga/openfga/security/advisories/GHSA-vj4m-83m8-xpw5 web
- https://nvd.nist.gov/vuln/detail/CVE-2022-39341 advisory
- https://github.com/openfga/openfga/commit/b466769cc100b2065047786578718d313f52695b web
- https://github.com/openfga/openfga package
- https://github.com/openfga/openfga/releases/tag/v0.2.4 web