GitHub Advisoryadvisory · PyPI

GHSA-vj87-jj27-4h9c wolfSSL Python module vulnerable to Improper Authentication

CRITICAL Published 2026-01-08 Modified 2026-01-30 Official page ↗
Aliases
CVE-2025-15346
Ecosystem
PyPI
Packages
wolfssl
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-287
Reviewed
2026-01-08

Affected packages

• PyPI wolfssl: < 5.8.4.post0 → fixed in 5.8.4.post0

Description

A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate requirements to not be fully enforced.  Because the WOLFSSL_VERIFY_FAIL_IF_NO_PEER_CERT flag was not included, the behavior effectively matched CERT_OPTIONAL: a peer certificate was verified if presented, but connections were incorrectly authenticated when no client certificate was provided.  This results in improper authentication, allowing attackers to bypass mutual TLS (mTLS) client authentication by omitting a client certificate during the TLS handshake.  The issue affects versions up to and including 5.8.2.

Related

Alias · CVE (1)

  • CVE-2025-15346 A vulnerability in the handling of verify_mode = CERT_REQUIRED in the wolfssl Python package (wolfssl-py) causes client certificate… vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References