GitHub Advisoryadvisory · npm

GHSA-vjp8-wprm-2jw9 OpenClaw has cross-account DM pairing authorization bypass via unscoped pairing store access

LOW Published 2026-03-04 Modified 2026-03-30 Official page ↗
Aliases
CVE-2026-32067
Ecosystem
npm
Packages
openclaw
Severity
Low
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-863
Reviewed
2026-03-04

Affected packages

• npm openclaw: < 2026.2.26 → fixed in 2026.2.26

Description

Summary OpenClaw had account-scope gaps in pairing-store access for DM pairing policy, which could let a pairing approval from one account authorize the same sender on another account in multi-account setups. Impact This is an authorization-boundary weakness in multi-account channel deployments. A sender approved in one account could be accepted in another account before explicit approval there. Affected Packages / Versions • Package: `openclaw` (npm) • Latest published version affected: `2026.2.25` • Vulnerable range: `= 2026.2.26` Fix OpenClaw now enforces account-scoped pairing reads/writes consistently across core and extension message channels, with stricter runtime/SDK helpers and shared policy wiring to prevent cross-account pairing bleed. Fix Commit(s) • `a0c5e28f3bf0cc0cd9311f9e9ec2ca0352550dcf` • `bce643a0bd145d3e9cb55400af33bd1b85baeb02` Release Process Note `patched_versions` is pre-set to the planned next release (`2026.2.26`). After npm publish of that version, this advisory is ready to publish without further content edits. OpenClaw thanks @tdjackey for reporting.

Related

Alias · CVE (1)

  • CVE-2026-32067 OpenClaw versions prior to 2026.2.26 contain an authorization bypass vulnerability in the pairing-store access control for direct message… vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References