GitHub Advisoryadvisory · Packagist

GHSA-vjqc-q4mp-2rvf CakePHP: Multiple methods in FunctionsBuilder vulnerable to SQL injection

CRITICAL Published 2026-09-17 Modified 2026-09-24 Official page ↗
Aliases
CVE-2026-79752
Ecosystem
Packagist
Packages
cakephp/database, cakephp/cakephp
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-89
Reviewed
2026-09-17

Affected packages

• Packagist cakephp/database: >= 3.0.0, < 4.5.12 → fixed in 4.5.12 • Packagist cakephp/database: >= 4.6.0, < 4.6.5 → fixed in 4.6.5 • Packagist cakephp/database: >= 5.0.0, < 5.1.9 → fixed in 5.1.9 • Packagist cakephp/database: >= 5.2.0, < 5.2.14 → fixed in 5.2.14 • Packagist cakephp/database: >= 5.3.0, < 5.3.7 → fixed in 5.3.7 • Packagist cakephp/cakephp: < 4.5.12 → fixed in 4.5.12 • Packagist cakephp/cakephp: >= 4.6.0, < 4.6.5 → fixed in 4.6.5 • Packagist cakephp/cakephp: >= 5.0.0, < 5.1.9 → fixed in 5.1.9 • Packagist cakephp/cakephp: >= 5.2.0, < 5.2.14 → fixed in 5.2.14 • Packagist cakephp/cakephp: >= 5.3.0, < 5.3.7 → fixed in 5.3.7

Description

Impact The `FunctionsBuilder::cast($field, $dataType)`, `extract($part, $expr)`, `datePart($part, $expr)`, `dateAdd($expr, $value, $unit)` methods are vulnerable to SQL injection if user controlled data is supplied to the ($dataType / $part / $unit) parameters. Patches 5.3.7, 5.2.14, 5.1.9, 4.6.5, 4.5.12 contain fixes Workarounds Don't provide user controlled data to these functions/parameters.

Related

Alias · CVE (1)

  • CVE-2026-79752 CakePHP is a rapid development framework for PHP. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References