GitHub Advisoryadvisory · Maven

GHSA-vjwc-5hfh-2vv5 Use of a Broken or Risky Cryptographic Algorithm in Apache WSS4J

HIGH Published 2022-05-14 Modified 2025-02-19 Official page ↗
Aliases
CVE-2015-0226
Ecosystem
Maven
Packages
org.apache.ws.security:wss4j, org.apache.wss4j:wss4j-ws-security-dom
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-327
Reviewed
2022-07-06

Affected packages

• Maven org.apache.ws.security:wss4j: < 1.6.17 → fixed in 1.6.17 • Maven org.apache.wss4j:wss4j-ws-security-dom: >= 2.0.0, < 2.0.2 → fixed in 2.0.2

Description

Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key or message data, which makes it easier for remote attackers to recover the plaintext form of a symmetric key via a series of crafted messages. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-2487.

Related

Alias · CVE (1)

  • CVE-2015-0226 Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks information about decryption failures when decrypting an encrypted key… vulnerability

Weakness · CWE (1)

  • CWE-327 Use of a Broken or Risky Cryptographic Algorithm weakness

References