GitHub Advisoryadvisory · Packagist
GHSA-vjxx-54vw-q59f Moodle SSRF Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-6970
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-918
- Reviewed
- 2023-07-19
Affected packages
• Packagist moodle/moodle: >= 3.5.0, < 3.5.4 → fixed in 3.5.4
Description
The `edit_blog.php` script allows a registered user to add external RSS feed resources. It was identified that this feature could be abused to be used as a SSRF attack vector by adding a malicious URL/TCP PORT in order to target internal network or an internet hosted server, bypassing firewall rules, IP filtering and more.
This kind of vulnerability is then called “blind” because of no response available on Moodle web site, enforcing attacker to exploit it using a “time based” approach.
Related
Alias · CVE (1)
- CVE-2019-6970 Moodle 3.5.x before 3.5.4 allows SSRF. vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-6970 advisory
- https://cds.thalesgroup.com/en/tcs-cert/CVE-2019-6970 web
- https://excellium-services.com/cert-xlm-advisory/cve-2019-6970 web
- https://github.com/moodle/moodle package
- https://www.excellium-services.com/cert-xlm-advisory web
- https://www.excellium-services.com/cert-xlm-advisory/cve-2019-6970 web