GitHub Advisoryadvisory · Packagist

GHSA-vm9c-39jx-q45w Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

MEDIUM Published 2022-05-13 Modified 2025-05-08 Official page ↗
Aliases
CVE-2013-4522
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-200
Reviewed
2025-05-08

Affected packages

• Packagist moodle/moodle: < 2.3.10 → fixed in 2.3.10 • Packagist moodle/moodle: >= 2.4.0-beta, < 2.4.7 → fixed in 2.4.7 • Packagist moodle/moodle: >= 2.5.0-beta, < 2.5.3 → fixed in 2.5.3

Description

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Related

Alias · CVE (1)

  • CVE-2013-4522 lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control:… vulnerability

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References