GitHub Advisoryadvisory · RubyGems
GHSA-vmfx-gcfq-wvm2 Nokogiri implementation of libxslt vulnerable to heap corruption
HIGH
Official page ↗
- Aliases
- CVE-2019-5815
- Ecosystem
- RubyGems
- Packages
- nokogiri
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-787, CWE-843
- Reviewed
- 2023-07-07
Affected packages
• RubyGems nokogiri: < 1.10.5 → fixed in 1.10.5
Description
Type confusion in `xsltNumberFormatGetMultipleLevel` prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.
Nokogiri prior to version 1.10.5 contains a vulnerable version of libxslt. Nokogiri version 1.10.5 upgrades the dependency to libxslt 1.1.34, which contains a patch for this issue.
Related
Alias · CVE (1)
- CVE-2019-5815 Type confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via… vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-5815 advisory
- https://github.com/sparklemotion/nokogiri/issues/2630 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2019-5815.yml web
- https://github.com/sparklemotion/nokogiri package
- https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b web
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html web