GitHub Advisoryadvisory · NuGet
GHSA-vmwf-m9c5-3jvc Microsoft Security Advisory CVE-2026-32178 – .NET Spoofing Vulnerability
LOW
Official page ↗
- Aliases
- CVE-2026-32178
- Ecosystem
- NuGet
- Packages
- Microsoft.NetCore.App.Runtime.linux-arm, Microsoft.NetCore.App.Runtime.linux-musl-arm, Microsoft.NetCore.App.Runtime.linux-arm64, Microsoft.NetCore.App.Runtime.linux-musl-x64, Microsoft.NetCore.App.Runtime.linux-musl-arm64, Microsoft.NetCore.App.Runtime.linux-x64, Microsoft.NetCore.App.Runtime.osx-arm64, Microsoft.NetCore.App.Runtime.osx-x64, Microsoft.NetCore.App.Runtime.win-arm, Microsoft.NetCore.App.Runtime.win-arm64, Microsoft.NetCore.App.Runtime.win-x64, Microsoft.NetCore.App.Runtime.win-x86
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:N
- Weaknesses
- CWE-138
- Reviewed
- 2026-04-14
Affected packages
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 10.0.0, < 10.0.6 → fixed in 10.0.6
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 9.0.0, < 9.0.15 → fixed in 9.0.15
• NuGet Microsoft.NetCore.App.Runtime.linux-arm: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.linux-arm64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-arm64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.linux-musl-x64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.linux-x64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.osx-arm64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.osx-x64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.win-arm: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.win-arm64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.win-x64: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
• NuGet Microsoft.NetCore.App.Runtime.win-x86: >= 8.0.0, < 8.0.26 → fixed in 8.0.26
Description
Executive Summary:
Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 8.0, .NET 9.0, and .NET 10.0. This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability.
A vulnerability exists in System.Net.Mail where specially crafted data allows an unauthorized attacker to perform a spoofing attack over the network.
Announcement
Announcement for this issue can be found at https://github.com/dotnet/announcements/issues/12345
CVSS Details
• Version: 3.1
• Severity: High
• Score: 7.5
• Vector: 7.5: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:U/RL:O/RC:C
• Weakness: CWE-138: Improper Neutralization of Special Elements
Affected Platforms
• Platforms: All
• Architectures: All
Affected Packages
The vulnerability affects any Microsoft .NET project if it uses any of affected package versions listed below
.NET 8
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, = 8.0.0, .NET 9
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, = 9.0.0, .NET 10
Package name | Affected version | Patched version
------------ | ---------------- | -------------------------
Microsoft.NetCore.App.Runtime.linux-arm | >= 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, = 10.0.0, How do I know if I am affected?
If using a package listed in affected packages, you're exposed to the vulnerability.
How do I fix the issue?
1. To fix the issue please install the latest version of .NET 8.0, NET 9.0, or .NET 10.0, as appropriate. If you have installed one or more .NET SDKs through Visual Studio, Visual Studio will prompt you to update Visual Studio, which will also update your .NET SDKs.
2. If your application references the vulnerable package, update the package reference to the patched version. You can list the versions you have installed by running the `dotnet --info` command.
Once you have installed the updated runtime or SDK, restart your apps for the update to take effect.
Additionally, if you've deployed [self-contained applications](https://do…
Related
Alias · CVE (1)
- CVE-2026-32178 Improper neutralization of special elements in .NET allows an unauthorized attacker to perform spoofing over a network. vulnerability
Weakness · CWE (1)
- CWE-138 Improper Neutralization of Special Elements weakness
References
- https://github.com/dotnet/runtime/security/advisories/GHSA-vmwf-m9c5-3jvc web
- https://nvd.nist.gov/vuln/detail/CVE-2026-32178 advisory
- https://github.com/dotnet/announcements/issues/12345 web
- https://github.com/dotnet/runtime package
- https://msrc.microsoft.com/update-guide/vulnerability/CVE-2026-32178 web