GitHub Advisoryadvisory · Maven
GHSA-vpfj-5gg5-fvfm XXE vulnerability in Jenkins Cobertura Plugin
HIGH
Official page ↗
- Aliases
- CVE-2020-2138
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:cobertura
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-611
- Reviewed
- 2023-01-05
Affected packages
• Maven org.jenkins-ci.plugins:cobertura: < 1.16 → fixed in 1.16
Description
Cobertura Plugin 1.15 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.
This allows a user able to control the input files for the 'Publish Cobertura Coverage Report' post-build step to have Jenkins parse a crafted file that uses external entities for extraction of secrets from the Jenkins controller or server-side request forgery.
Cobertura Plugin 1.16 disables external entity resolution for its XML parser.
Related
Alias · CVE (1)
- CVE-2020-2138 Jenkins Cobertura Plugin 1.15 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks. vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2138 advisory
- https://github.com/jenkinsci/cobertura-plugin/commit/fdee535fe4782181d822b875c96df8306f245d48 web
- https://github.com/jenkinsci/cobertura-plugin package
- https://jenkins.io/security/advisory/2020-03-09/#SECURITY-1700 web
- http://www.openwall.com/lists/oss-security/2020/03/09/1 web