GitHub Advisoryadvisory · Maven

GHSA-vpfp-5gwq-g533 Improper Authentication in Apache ShenYu Admin

CRITICAL Published 2021-11-17 Modified 2023-09-05 Official page ↗
Aliases
CVE-2021-37580
Ecosystem
Maven
Packages
org.apache.shenyu:shenyu-admin
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287
Reviewed
2021-11-17

Affected packages

• Maven org.apache.shenyu:shenyu-admin: >= 2.3.0, < 2.4.1 → fixed in 2.4.1

Description

A flaw was found in Apache ShenYu Admin. The incorrect use of JWT in ShenyuAdminBootstrap allows an attacker to bypass authentication. This issue affected Apache ShenYu 2.3.0 and 2.4.0.

Related

Alias · CVE (1)

  • CVE-2021-37580 A flaw was found in Apache ShenYu Admin. vulnerability

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References