GitHub Advisoryadvisory · npm

GHSA-vpj2-qq7w-5qq6 parse-server has cloud function validator bypass via prototype chain traversal

CRITICAL Published 2026-03-31 Modified 2026-03-31 Official page ↗
Aliases
CVE-2026-34532
Ecosystem
npm
Packages
parse-server
Severity
Critical
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
Weaknesses
CWE-863
Reviewed
2026-03-31

Affected packages

• npm parse-server: >= 9.0.0, < 9.7.0-alpha.11 → fixed in 9.7.0-alpha.11 • npm parse-server: < 8.6.67 → fixed in 8.6.67

Description

Impact An attacker can bypass Cloud Function validator access controls by appending `.prototype.constructor` to the function name in the URL. When a Cloud Function handler is declared using the `function` keyword and its validator is a plain object or arrow function, the trigger store traversal resolves the handler through its own prototype chain while the validator store fails to mirror this traversal, causing all access control enforcement to be skipped. This allows unauthenticated callers to invoke Cloud Functions that are meant to be protected by validators such as `requireUser`, `requireMaster`, or custom validation logic. Patches The trigger store traversal now verifies that each intermediate node is a legitimate store object before continuing traversal. If the traversal encounters a non-store value such as a function handler, it stops and returns an empty store, preventing prototype chain escape. Workarounds Use arrow functions instead of the `function` keyword for Cloud Function handlers. Arrow functions do not have a `prototype` property and are not affected by this vulnerability. Resources • GitHub security advisory: https://github.com/parse-community/parse-server/security/advisories/GHSA-vpj2-qq7w-5qq6 • Fix Parse Server 9: https://github.com/parse-community/parse-server/pull/10342 • Fix Parse Server 8: https://github.com/parse-community/parse-server/pull/10343

Related

Alias · CVE (1)

  • CVE-2026-34532 Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. vulnerability

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References