GitHub Advisoryadvisory · Packagist
GHSA-vq4j-qcx7-ppc6 Thelia Cross-site Scripting vulnerability in BackOffice
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- thelia/thelia
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-30
Affected packages
• Packagist thelia/thelia: >= 2.1.0, < 2.1.2 → fixed in 2.1.2
Description
The BackOffice of Thelia (`error.html` template) has a cross-site scripting vulnerability in version 2.1.0 and 2.1.1 but not version 2.0.X. Version 2.1.2 contains a patch for the issue.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/thelia/thelia/commit/e7c9c3be1d580067cba102f1f9530baf067c1e5d web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/thelia/thelia/2015-02-24-1.yaml web
- https://github.com/thelia/thelia package
- https://web.archive.org/web/20160406004324/http://thelia.net/version-2-1-2-with-security-fix web