GitHub Advisoryadvisory · Maven
GHSA-vq7p-f4fv-rr5x Jenkins vSphere Plugin disables SSL/TLS certificate validation by default
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1000151
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:vsphere-cloud
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-295
- Reviewed
- 2022-12-12
Affected packages
• Maven org.jenkins-ci.plugins:vsphere-cloud: < 2.17 → fixed in 2.17
Description
A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in VSphere.java that disables SSL/TLS certificate validation by default. vSphere Plugin 2.17 now has SSL/TLS certificate validation enabled by default.
Related
Alias · CVE (1)
- CVE-2018-1000151 A man in the middle vulnerability exists in Jenkins vSphere Plugin 2.16 and older in VSphere.java that disables SSL/TLS certificate… vulnerability
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness