GitHub Advisoryadvisory · Packagist

GHSA-vqcm-r62w-w437 phpMyAdmin remote variable manipulation

MEDIUM Published 2022-05-14 Modified 2024-01-15 Official page ↗
Aliases
CVE-2011-2505
Ecosystem
Packagist
Packages
phpmyadmin/phpmyadmin
Severity
Moderate
Weaknesses
CWE-94
Reviewed
2024-01-15

Affected packages

• Packagist phpmyadmin/phpmyadmin: >= 3.0, < 3.3.10.2 → fixed in 3.3.10.2 • Packagist phpmyadmin/phpmyadmin: >= 3.4, < 3.4.3.1 → fixed in 3.4.3.1

Description

`libraries/auth/swekey/swekey.auth.lib.php` in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the `SESSION` superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Related

Alias · CVE (1)

  • CVE-2011-2505 libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References