GitHub Advisoryadvisory · Maven
GHSA-vqp8-h53h-3jfh Stored XSS vulnerability in Jenkins VncRecorder Plugin
MEDIUM
Official page ↗
- Aliases
- CVE-2020-2205
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:vncrecorder
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-12-29
Affected packages
• Maven org.jenkins-ci.plugins:vncrecorder: < 1.35 → fixed in 1.35
Description
VncRecorder Plugin 1.25 and earlier does not escape a tool path in the `checkVncServ` form validation endpoint accessed e.g. via job configuration forms.
This results in a stored cross-site scripting (XSS) vulnerability exploitable by Jenkins administrators.
VncRecorder Plugin 1.35 escapes the tool path.
Related
Alias · CVE (1)
- CVE-2020-2205 Jenkins VncRecorder Plugin 1.25 and earlier does not escape a tool path in the `checkVncServ` form validation endpoint, resulting in a… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness