GitHub Advisoryadvisory · Packagist
GHSA-vqqr-fgmh-f626 Contao Vulnerable to Cross-Site Scripting (XSS) through SVG uploads
MEDIUM
Official page ↗
- Aliases
- CVE-2025-29790
- Ecosystem
- Packagist
- Packages
- contao/core-bundle
- Severity
- Moderate
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-03-18
Affected packages
• Packagist contao/core-bundle: >= 4.0.0, < 4.13.54 → fixed in 4.13.54
• Packagist contao/core-bundle: >= 5.3.0, < 5.3.30 → fixed in 5.3.30
• Packagist contao/core-bundle: >= 5.4.0, < 5.5.6 → fixed in 5.5.6
Description
Impact
Users can upload SVG files with malicious code, which is then executed in the back end and/or front end.
Patches
Update to Contao 4.13.54, 5.3.30 or 5.5.6.
Workarounds
Remove `svg,svgz` from the allowed upload file types in the system settings and from `contao.editable_files` in the `config.yaml`.
References
https://contao.org/en/security-advisories/cross-site-scripting-through-svg-uploads
For more information
If you have any questions or comments about this advisory, open an issue in contao/contao.
Related
Alias · CVE (1)
- CVE-2025-29790 Contao is an Open Source CMS. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness