GitHub Advisoryadvisory · Go
GHSA-vqwh-5jhh-vc9p Mattermost Server SSRF Vulnerability via the Agents Plugin
LOW
Official page ↗
- Aliases
- CVE-2025-47700
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-918
- Reviewed
- 2025-08-21
Affected packages
• Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.10 → fixed in 10.5.10
• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20250814075248-83a37a861d3c → fixed in 8.0.0-20250814075248-83a37a861d3c
Description
Mattermost Server versions 10.5.x <= 10.5.9 utilizing the Agents plugin fail to reject empty request bodies which allows users to trick users into clicking malicious links via post actions
Related
Alias · CVE (1)
- CVE-2025-47700 Mattermost Server versions 10.5.x <= 10.5.9 utilizing the Agents plugin fail to reject empty request bodies which allows users to trick… vulnerability
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness