GitHub Advisoryadvisory · PyPI

GHSA-vqxf-v2gg-x3hc docling-core vulnerable to Remote Code Execution via unsafe PyYAML usage

HIGH Published 2026-01-22 Modified 2026-01-22 Official page ↗
Aliases
CVE-2026-24009
Ecosystem
PyPI
Packages
docling-core
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2026-01-22

Affected packages

• PyPI docling-core: >= 2.21.0, < 2.48.4 → fixed in 2.48.4

Description

Impact A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in `docling-core >=2.21.0, <2.48.4` and, specifically only if the application uses `pyyaml < 5.4` and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. Patches The vulnerability has been patched in `docling-core` version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Workarounds Users who cannot immediately upgrade `docling-core` can alternatively ensure that the installed version of `PyYAML` is 5.4 or greater, which supposedly patches CVE-2020-14343. References • GitHub Issue: #482 • Upstream Advisory: CVE-2020-14343 • Fix Release: v2.48.4

Related

Alias · CVE (1)

  • CVE-2026-24009 Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References