GitHub Advisoryadvisory · Packagist

GHSA-vr6v-g96p-cjc3 Moodle vulnerable to RCE

HIGH Published 2022-05-24 Modified 2023-08-21 Official page ↗
Aliases
CVE-2020-10738
Ecosystem
Packagist
Packages
moodle/moodle
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Reviewed
2023-07-13

Affected packages

• Packagist moodle/moodle: >= 3.8, < 3.8.3 → fixed in 3.8.3 • Packagist moodle/moodle: >= 3.7, < 3.7.6 → fixed in 3.7.6 • Packagist moodle/moodle: >= 3.6, < 3.6.10 → fixed in 3.6.10 • Packagist moodle/moodle: >= 3.5, < 3.5.12 → fixed in 3.5.12

Description

A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported versions. It was possible to create a SCORM package in such a way that when added to a course, it could be interacted with via web services in order to achieve remote code execution.

Related

Alias · CVE (1)

  • CVE-2020-10738 A flaw was found in Moodle versions 3.8 before 3.8.3, 3.7 before 3.7.6, 3.6 before 3.6.10, 3.5 before 3.5.12 and earlier unsupported… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References