GitHub Advisoryadvisory · Packagist

GHSA-vr95-p7q6-8m9q Laravel Cross-site Scripting (XSS) vulnerability in blade templating

MEDIUM Published 2024-05-15 Modified 2024-05-15 Official page ↗
Ecosystem
Packagist
Packages
laravel/framework
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-15

Affected packages

• Packagist laravel/framework: >= 7.0.0, < 7.1.2 → fixed in 7.1.2

Description

Laravel 7.1.2 addresses a possible XSS related attack vector in the Laravel 7.x Blade Component tag attributes when users are allowed to dictate the value of attributes. All Laravel 7.x users are encouraged to upgrade as soon as possible.

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References