GitHub Advisoryadvisory · PyPI, npm, RubyGems, crates.io
GHSA-vrcx-gx3g-j3h8 Heap-based Buffer Overflow in sqlite-vec
HIGH
Official page ↗
- Aliases
- CVE-2024-46488
- Ecosystem
- PyPI, npm, RubyGems, crates.io
- Packages
- sqlite-vec
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- Weaknesses
- CWE-122, CWE-787
- Reviewed
- 2024-09-25
Affected packages
• PyPI sqlite-vec: < 0.1.3 → fixed in 0.1.3
• npm sqlite-vec: < 0.1.3 → fixed in 0.1.3
• RubyGems sqlite-vec: < 0.1.3 → fixed in 0.1.3
• crates.io sqlite-vec: < 0.1.3 → fixed in 0.1.3
Description
sqlite-vec v0.1.1 was discovered to contain a heap buffer overflow via the npy_token_next function. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted file.
Related
Alias · CVE (1)
- CVE-2024-46488 sqlite-vec v0.1.1 was discovered to contain a heap buffer overflow via the npy_token_next function. vulnerability
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-46488 advisory
- https://github.com/VulnSphere/LLMVulnSphere/blob/main/VectorDB/sqlite-vec/OOBR_2.md web
- https://github.com/advisories/GHSA-vrcx-gx3g-j3h8 advisory
- https://github.com/asg017/sqlite-vec package
- https://github.com/asg017/sqlite-vec/releases/tag/v0.1.3 web
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sqlite-vec/CVE-2024-46488.yml web