GitHub Advisoryadvisory · Packagist
GHSA-vrpv-26fm-7vf7 EC-CUBE Cross-site scripting vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2021-20750
- Ecosystem
- Packagist
- Packages
- ec-cube/ec-cube
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-25
Affected packages
• Packagist ec-cube/ec-cube: >= 3.0.0, <= 3.0.18-p2 (no fix yet)
• Packagist ec-cube/ec-cube: >= 4.0.0, < 4.0.6 → fixed in 4.0.6
Description
Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4 series) allows a remote attacker to inject an arbitrary script by leading an administrator or a user to a specially crafted page and to perform a specific operation.
Related
Alias · CVE (1)
- CVE-2021-20750 Cross-site scripting vulnerability in EC-CUBE EC-CUBE 3.0.0 to 3.0.18-p2 (EC-CUBE 3 series) and EC-CUBE 4.0.0 to 4.0.5-p1 (EC-CUBE 4… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness