GitHub Advisoryadvisory · npm

GHSA-vrv8-v4w8-f95h Cross-site scripting vulnerability in TinyMCE

MEDIUM Published 2020-08-11 Modified 2023-05-22 Official page ↗
Aliases
CVE-2020-12648
Ecosystem
npm
Packages
tinymce
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-08-10

Affected packages

• npm tinymce: < 4.9.11 → fixed in 4.9.11 • npm tinymce: >= 5.0.0, < 5.4.1 → fixed in 5.4.1

Description

Impact A cross-site scripting (XSS) vulnerability was discovered in the core parser. The vulnerability allowed arbitrary JavaScript execution when inserting a specially crafted piece of content into the editor via the clipboard or APIs. This impacts all users who are using TinyMCE 4.9.10 or lower and TinyMCE 5.4.0 or lower. Patches This vulnerability has been patched in TinyMCE 4.9.11 and 5.4.1 by improved HTML parsing and sanitization logic. Workarounds The workarounds available are: • upgrade to either TinyMCE 4.9.11 or TinyMCE 5.4.1 or • enable the media plugin, which overrides the default parsing behaviour for iframes or • add the following workaround to update the parsing schema rules for iframes: Example: Change the default schema for iframes ```js setup: function(editor) { editor.on('PreInit', function() { editor.schema.getSpecialElements()['iframe'] = /]*>/gi; }); } ``` Acknowledgements Tiny Technologies would like to thank George Steketee and Chris Davis at Bishop Fox for discovering this vulnerability. References https://www.tiny.cloud/docs/release-notes/release-notes54/#securityfixes For more information If you have any questions or comments about this advisory: • Open an issue in the TinyMCE repo • Email us at [email protected]

Related

Alias · CVE (1)

  • CVE-2020-12648 A cross-site scripting (XSS) vulnerability in TinyMCE 5.2.1 and earlier allows remote attackers to inject arbitrary web script when… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References