GitHub Advisoryadvisory · Maven
GHSA-vrx2-mgr9-v67h Apache Ranger has Stored Cross-site Scripting vulnerability in Edit Service Page
MEDIUM
Official page ↗
- Aliases
- CVE-2024-45478
- Ecosystem
- Maven
- Packages
- org.apache.ranger:ranger
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-20, CWE-79
- Reviewed
- 2025-06-10
Affected packages
• Maven org.apache.ranger:ranger: < 2.5.0 → fixed in 2.5.0
Description
Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0.
Users are recommended to upgrade to version Apache Ranger 2.5.0, which fixes this issue.
Related
Alias · CVE (1)
- CVE-2024-45478 Stored XSS vulnerability in Edit Service Page of Apache Ranger UI in Apache Ranger Version 2.4.0. vulnerability