GitHub Advisoryadvisory · npm
GHSA-vv7x-7w4m-q72f fhir-works-on-aws-authz-smart handles permissions improperly
MEDIUM
Official page ↗
- Aliases
- CVE-2022-39230
- Ecosystem
- npm
- Packages
- fhir-works-on-aws-authz-smart
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-281
- Reviewed
- 2022-09-21
Affected packages
• npm fhir-works-on-aws-authz-smart: >= 3.1.1, < 3.1.3 → fixed in 3.1.3
Description
Impact
This issue allows a client of the API to retrieve more information than the client’s OAuth scope permits when making “search-type” requests. This issue would not allow a client to retrieve information about individuals other than those the client was already authorized to access.
Patches
We recommend that users of fhir-works-on-aws-authz-smart 3.1.1 or 3.1.2 upgrade to version 3.1.3 or higher immediately. Versions 3.1.0 and below are unaffected.
Workarounds
There is no workaround for this issue. Please upgrade fhir-works-on-aws-authz-smart to version 3.1.3 or higher.
References
https://github.com/awslabs/fhir-works-on-aws-deployment
https://github.com/awslabs/fhir-works-on-aws-authz-smart
For more information
If you have any questions or comments about this advisory:
Email us at [email protected]
Related
Alias · CVE (1)
- CVE-2022-39230 fhir-works-on-aws-authz-smart is an implementation of the authorization interface from the FHIR Works interface. vulnerability
References
- https://github.com/awslabs/fhir-works-on-aws-authz-smart/security/advisories/GHSA-vv7x-7w4m-q72f web
- https://nvd.nist.gov/vuln/detail/CVE-2022-39230 advisory
- https://github.com/awslabs/fhir-works-on-aws-authz-smart/commit/203bbc0dd17de748c36b33c68b866ed2dfd613d3 web
- https://github.com/awslabs/fhir-works-on-aws-authz-smart package