GitHub Advisoryadvisory · Packagist

GHSA-vvg7-8rmq-92g7 Auth0 WordPress has Improper Audience Validation via Auth0-PHP SDK Dependency

MEDIUM Published 2025-12-17 Modified 2025-12-17 Official page ↗
Ecosystem
Packagist
Packages
auth0/wordpress
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-1395, CWE-863
Reviewed
2025-12-17

Affected packages

• Packagist auth0/wordpress: >= 5.0.0-BETA0, < 5.5.0 → fixed in 5.5.0

Description

Description In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Affected product and versions Projects are affected if they meet the following preconditions: • Applications using the Auth0 Wordpress plugin with version between 5.0.0-BETA0 and 5.4.0, • Auth0 Wordpress plugin uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. Resolution Upgrade Auth0 Wordpress plugin to version 5.5.0 or greater. Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

Related

Weakness · CWE (2)

  • CWE-1395 Dependency on Vulnerable Third-Party Component weakness
  • CWE-863 Incorrect Authorization weakness

References