GitHub Advisoryadvisory · npm

GHSA-vvgp-4c28-m3jm OpenClaw has a Trusted-proxy Control UI pairing bypass which allows unpaired node sessions

MEDIUM Published 2026-03-03 Modified 2026-03-30 Official page ↗
Aliases
CVE-2026-32057
Ecosystem
npm
Packages
openclaw
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
Weaknesses
CWE-807
Reviewed
2026-03-03

Affected packages

• npm openclaw: < 2026.2.25 → fixed in 2026.2.25

Description

Summary A trusted-proxy Control UI pairing bypass accepted `client.id=control-ui` without device identity checks. The bypass did not require `operator` role, so an authenticated `node` role session could connect unpaired and reach node event methods. Impact With trusted-proxy authentication enabled, a `node` role websocket client could skip pairing by using `client.id=control-ui`. That created an authorization boundary bypass from a node-scoped connection into node event execution flows. Affected Packages / Versions • Package: `openclaw` (npm) • Affected range: `<= 2026.2.24` • Latest published vulnerable version: `2026.2.24` • Patched in next release: `2026.2.25` (pre-set below so this advisory is ready to publish after npm release) Fix The trusted-proxy Control UI bypass now additionally requires `role === "operator"`. Fix Commit(s) • `ec45c317f5d0631a3d333b236da58c4749ede2a3` Release Process Note `patched_versions` is intentionally pre-set to the release (`2026.2.25`). Advisory published with npm release `2026.2.25`.2.25` is published, the remaining GHSA action is to publish this advisory. OpenClaw thanks @tdjackey for reporting.

Related

Alias · CVE (1)

  • CVE-2026-32057 OpenClaw versions prior to 2026.2.25 contain an authentication bypass vulnerability in the trusted-proxy Control UI pairing mechanism that… vulnerability

Weakness · CWE (1)

  • CWE-807 Reliance on Untrusted Inputs in a Security Decision weakness

References