GitHub Advisoryadvisory · RubyGems

GHSA-vvqw-fqwx-mqmm Decidim::Admin vulnerable to cross-site scripting (XSS) in the admin panel with QuillJS WYSWYG editor

MEDIUM Published 2024-09-16 Modified 2024-09-17 Official page ↗
Aliases
CVE-2024-39910
Ecosystem
RubyGems
Packages
decidim
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:N/A:N
Weaknesses
CWE-79
Reviewed
2024-09-16

Affected packages

• RubyGems decidim: < 0.27.7 → fixed in 0.27.7

Description

Impact The WYSWYG editor QuillJS is subject to potential XSS attach in case the attacker manages to modify the HTML before being uploaded to the server. The attacker is able to change e.g. to if they know how to craft these requests themselves. Patches N/A Workarounds Review the user accounts that have access to the admin panel (i.e. general Administrators, and participatory space's Administrators) and remove access to them if they don't need it. Disable the "Enable rich text editor for participants" setting in the admin dashboard References OWASP ASVS v4.0.3-5.1.3

Related

Alias · CVE (1)

  • CVE-2024-39910 decidim is a Free Open-Source participatory democracy, citizen participation and open government for cities and organizations. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References