GitHub Advisoryadvisory · PyPI
GHSA-vwgf-7f9h-h499 Cross site scripting in zenml
LOW
Official page ↗
- Aliases
- CVE-2024-2171
- Ecosystem
- PyPI
- Packages
- zenml
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-06-06
Affected packages
• PyPI zenml: < 0.56.2 → fixed in 0.56.2
Description
A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. By injecting malicious payloads into this field, an attacker could send harmful messages to other users, potentially compromising their accounts. The vulnerability affects version 0.55.3 and was fixed in version 0.56.2. The impact of exploiting this vulnerability could lead to user account compromise.
Related
Alias · CVE (1)
- CVE-2024-2171 A stored Cross-Site Scripting (XSS) vulnerability was identified in the zenml-io/zenml repository, specifically within the 'logo_url' field. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-2171 advisory
- https://github.com/zenml-io/zenml/commit/68bcb3ba60cba9729c9713a49c39502d40fb945e web
- https://github.com/pypa/advisory-database/tree/main/vulns/zenml/PYSEC-2024-170.yaml web
- https://github.com/zenml-io/zenml package
- https://huntr.com/bounties/cee06a28-7e3b-460b-b504-69add838ebe8 web