GitHub Advisoryadvisory · Packagist

GHSA-vwhw-vp9v-q9c9 Moodle vulnerable to Cross-site Scripting

MEDIUM Published 2026-02-03 Modified 2026-02-03 Official page ↗
Aliases
CVE-2025-67855
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2026-02-03

Affected packages

• Packagist moodle/moodle: < 4.1.22 → fixed in 4.1.22 • Packagist moodle/moodle: >= 4.4.0-beta, < 4.4.12 → fixed in 4.4.12 • Packagist moodle/moodle: >= 4.5.0-beta, < 4.5.8 → fixed in 4.5.8 • Packagist moodle/moodle: >= 5.0.0-beta, < 5.0.4 → fixed in 5.0.4 • Packagist moodle/moodle: >= 5.1.0-beta, < 5.1.1 → fixed in 5.1.1

Description

A flaw was found in Moodle. A remote attacker could exploit a reflected Cross-Site Scripting (XSS) vulnerability in the policy tool return URL. This vulnerability arises from insufficient sanitization of URL parameters, allowing attackers to inject malicious scripts through specially crafted links. Successful exploitation could lead to information disclosure or arbitrary client-side script execution within the user's browser.

Related

Alias · CVE (1)

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References