GitHub Advisoryadvisory · Maven
GHSA-vwjx-mmwm-pwrf Lucee RCE/XXE Vulnerability
CRITICAL
Official page ↗
- Aliases
- CVE-2023-38693
- Ecosystem
- Maven
- Packages
- org.lucee:lucee
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-611
- Reviewed
- 2025-03-05
Affected packages
• Maven org.lucee:lucee: >= 5.3.10.79-RC, < 5.3.12.1 → fixed in 5.3.12.1
• Maven org.lucee:lucee: >= 5.4.0.65-RC, < 5.4.3.2 → fixed in 5.4.3.2
• Maven org.lucee:lucee: <= 5.3.7.59 (no fix yet)
• Maven org.lucee:lucee: >= 5.3.8.132-RC, < 5.3.8.236 → fixed in 5.3.8.236
• Maven org.lucee:lucee: >= 5.3.9.113, < 5.3.9.173 → fixed in 5.3.9.173
Description
Impact
The Lucee team received a responsible disclosure of a security vulnerability which affects all previous releases of Lucee.
After reviewing the report and confirming the vulnerability, the Lucee team then conducted a further security review and found additional vulnerabilities which have been addressed as part of this this security update.
Patches
Lucee 5.4.3.2 and 5.3.12.1 stable releases have been patched with additional hardening
The older releases, 5.3.7.59., 5.3.8.236 and 5.3.9.173 have also been patched
Any users running older release, should plan to immediately upgrade to the latest stable release
6.0 will have a RC as it's not yet released
Related
Alias · CVE (1)
- CVE-2023-38693 Lucee Server (or simply Lucee) is a dynamic, Java based, tag and scripting language used for rapid web application development. vulnerability
Weakness · CWE (1)
- CWE-611 Improper Restriction of XML External Entity Reference weakness