GitHub Advisoryadvisory · Packagist
GHSA-vwqw-wfhv-2xcq MODX vulnerability allows for XSS via user settings parameters
MEDIUM
Official page ↗
- Aliases
- CVE-2018-20758
- Ecosystem
- Packagist
- Packages
- modx/revolution
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-07-11
Affected packages
• Packagist modx/revolution: < 2.7.1-pl → fixed in 2.7.1-pl
Description
MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description.
Related
Alias · CVE (1)
- CVE-2018-20758 MODX Revolution through v2.7.0-pl allows XSS via User Settings such as Description. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness