GitHub Advisoryadvisory · PyPI
GHSA-vwrc-g9q6-f675 Zope Server vulnerable to DoS via header injection
MEDIUM
Official page ↗
- Aliases
- CVE-2002-0687
- Ecosystem
- PyPI
- Packages
- zope
- Severity
- Moderate
- Weaknesses
- CWE-400
- Reviewed
- 2024-02-12
Affected packages
• PyPI zope: >= 2.0.0, < 2.4.4b2 → fixed in 2.4.4b2
• PyPI zope: >= 2.5.0, < 2.5.1b2 → fixed in 2.5.1b2
Description
Zope is a Web application server for Linux. Zope versions 2.0 through 2.5.1 b1 are vulnerable to a denial of service attack, caused by a vulnerability that occurs when using the "through the Web code" capability. A remote attacker could inject malicious headers into a response to cause the vulnerable system to crash.
Related
Alias · CVE (1)
- CVE-2002-0687 The "through the web code" capability for Zope 2.0 through 2.5.1 b1 allows untrusted users to shut down the Zope server via certain headers. vulnerability
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2002-0687 advisory
- https://marc.info/?l=zope-announce&m=101890177815066&w=2 web
- https://marc.info/?l=zope-announce&m=101897461507941&w=2 web
- https://marc.info/?l=zope-announce&m=101897462107967&w=2 web
- https://web.archive.org/web/20020822024423/http://www.iss.net/security_center/static/9621.php web
- https://web.archive.org/web/20021018100409/http://online.securityfocus.com/bid/5813 web
- http://www.redhat.com/support/errata/RHSA-2002-060.html web
- http://www.zope.org/Products/Zope/Hotfix_2002-04-15/security_alert web