GitHub Advisoryadvisory · Maven

GHSA-vwxj-6m5m-rrvh The REST Plugin in Apache Struts is using an outdated XStream library

HIGH Published 2018-10-16 Modified 2022-04-26 Official page ↗
Aliases
CVE-2017-9793
Ecosystem
Maven
Packages
org.apache.struts:struts2-rest-plugin
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• Maven org.apache.struts:struts2-rest-plugin: < 2.3.34 → fixed in 2.3.34 • Maven org.apache.struts:struts2-rest-plugin: >= 2.5.0, < 2.5.13 → fixed in 2.5.13

Description

The REST Plugin in Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.

Related

Alias · CVE (1)

  • CVE-2017-9793 The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References