GitHub Advisoryadvisory · crates.io
GHSA-vx24-x4mv-vwr5 Starship vulnerable to shell injection via undocumented, unpredictable shell expansion in custom commands
HIGH
Official page ↗
- Aliases
- CVE-2024-41815
- Ecosystem
- crates.io
- Packages
- starship
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77, CWE-78
- Reviewed
- 2024-07-26
Affected packages
• crates.io starship: >= 1.0.0, < 1.20.0 → fixed in 1.20.0
Description
Description
Starship is a cross-shell prompt. Starting in version 1.0.0 and prior to version 1.20.0, undocumented and unpredictable shell expansion and/or quoting rules make it easily to accidentally cause shell injection when using custom commands with starship in bash. Version 1.20.0 fixes the vulnerability.
PoC
Have some custom command which prints out information from a potentially untrusted/unverified source.
```
[custom.git_commit_name]
command = 'git show -s --format="%<(25,mtrunc)%s"'
style = "italic"
when = true
```
Impact
This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone.
Related
Alias · CVE (1)
- CVE-2024-41815 Starship is a cross-shell prompt. vulnerability
References
- https://github.com/starship/starship/security/advisories/GHSA-vx24-x4mv-vwr5 web
- https://nvd.nist.gov/vuln/detail/CVE-2024-41815 advisory
- https://github.com/starship/starship/commit/cfc58161e0ec595db90af686ad77a73df6d44d74 web
- https://github.com/starship/starship package
- https://github.com/starship/starship/releases/tag/v1.20.0 web
- https://rustsec.org/advisories/RUSTSEC-2024-0446.html web