GitHub Advisoryadvisory · Packagist

GHSA-vx7m-v8v2-fhwm Magento 2 Community Edition XSS Vulnerability

MEDIUM Published 2022-05-24 Modified 2023-09-26 Official page ↗
Aliases
CVE-2019-8131
Ecosystem
Packagist
Packages
magento/community-edition
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-07-18

Affected packages

• Packagist magento/community-edition: >= 2.2.0, < 2.2.10 → fixed in 2.2.10 • Packagist magento/community-edition: >= 2.3.0, < 2.3.2-p1 → fixed in 2.3.2-p1

Description

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can inject arbitrary JavaScript code into code field of an inventory source.

Related

Alias · CVE (1)

  • CVE-2019-8131 A stored cross-site scripting (XSS) vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References